Back to overview
Resolved

Server Upgrade

Jul 26, 2026 at 4:05pm UTC  –  Jul 26, 2026 at 4:30pm UTC
Affected services
Billing Portal | billing.lilypawdigital.com
LON-VPS-1 | AKA WALL-E

Resolved
Jul 26, 2026 at 4:30pm UTC

Maintenance ended

Created
Jul 26, 2026 at 4:05pm UTC

Server Upgrade